I have recently faced one interview in which I was asked all this questions on various flavors of Linux. I have included my answers for which I know about the technology. All questions are for command line use in Linux environments. Q: How do you display your running kernel version? (Solaris, AIX, Linux) A: Linux # uname –r , Solaris # showrev
Q: Which command do you use to display a table of running processes? (Solaris, AIX, Linux) A: Linux # ps –ef and top , Solaris # prstat
Q: Which file do you modify to configure a domain name resolver? (Solaris, AIX, Linux) A: Linux # /etc/resolv.conf , Solaris # /etc/resolv.conf
Q: Which file contains a list of locally defined hostnames and corresponding IP addresses? (Solaris, AIX, Linux) A: Linux # /etc/hosts , Solaris # /etc/hosts and linked
file /etc/inet/hosts
Q: How do you display a routing table? (Solaris, AIX, Linux) A: Linux # ip route show or #netstat –nr or #route –n
and Solaris # netstat –nr and #route -n
Q: which command would you use to create an OS user on Solaris and Linux? A: Linux # useradd and Solaris #useradd
Q: Which file contains passwords for local users on Solaris, Linux and on AIX? A: Linux #/etc/shadow and Solaris # /etc/shadow
Q: Which command would you use to list partitions on Linux? A: Linux # mount –l or # df -kh
Q: Which command/commands would you use to manage installed packages on RedHat Linux? A: Linux # rpm
Q: Which file has a list of filesystems to be mounted at boot time on Solaris, Linux and AIX? A: Linux # /etc/fstab and Solaris #/etc/vfstab
Have a Linux Problem
Linux Books
Linux Home: Linux System Administration Hints and Tips (c) www.gotothings.com All material on this site is Copyright.
|